RICOH Interactive Whiteboard Add-on Service Site
Incident Report for RICOH IWB Add-on Service (NA)
Resolved
This incident has been resolved.
Posted Jan 10, 2020 - 16:00 JST
Identified
Cannot log-in to "RICOH Interactive Whiteboard Add-on Service Site" with direct url(https://apps.cf.na.smart-integration.ricoh.com/iwb/) .
Please access to "RICOH Interactive Whiteboard Add-on Service Site" from https://na.accounts.ricoh.com/
Posted Jan 09, 2020 - 16:30 JST
This incident affected: RICOH Interactive Whiteboard Add-on Service (NA).